Migration des Brückenkurses

Hier befinden sich alle notwendigen Informationen zur Migration der Inhalte des Brückenkurses in die neue Mumie. Eure Aufgabe wird es einerseits sein, die existierenden Inhalte des Brückenkurses in Mumie-TeX zu übersetzen. Andererseits werdet ihr zweifellos noch neue Bugs und fehlende Features entdecken. Es geht hier zunächst weniger darum, die Inhalte schon zu perfektionieren, als vielmehr die Fehler und Stolperstellen in der neuen Arbeitsumgebung zu finden und zu beseitigen.

Benutzung des neuen Miau

ACHTUNG Es gibt anscheinend noch Probleme damit, dass das neue Miau nicht das richtige Java findet. Vorläufig hilft dabei folgendes Vorgehen bei der Installation:

  1. Kommandozeile starten, z.B. ein xterm
  2. bash starten, falls das nicht eure Loginshell ist (seht ihr mit echo $0)
  3. Miau wie gewohnt entpacken
  4. PATH=/usr/lib64/jvm/java-sun/jre/bin/:$PATH ./miau.sh

Danach könnt ihr wie gewohnt Miau mit ./miau.sh aufrufen.

Das neue Miau ist mittlerweile so stabil, dass wir wieder zum gewohnten Arbeitsrythmus übergehen. Das heißt, dass ihr es nicht mehr selber aus einem Eclipse heraus startet, sondern es komplett bei euch installiert. Dazu findet ihr unter

/net/mumie/miau/miau_build

die .zip-Datei mit der neuesten Version. Diese könnt ihr einfach an einer geeigneten Stelle in eurem Home unzippen. Das erzeugt ein Verzeichnis miau, in dem ihr das Script miau.sh startet. Vorsicht: Ihr dürft miau nicht am gleichen Ort installieren wie das Miau für die Analyis, weil sonst das alte Miau überschrieben wird. Macht euch dafür am besten ein eigenes Verzeichnis.

In Miau wird wahrscheinlich zunächst euer alter Workspace erscheinen, den ihr für die Analysis-Inhalte verwendet. Ihr müsst euch einen zweiten Workspace für die neuen OMB-Inhalte erstellen. Dazu wählt ihr im Menü Window->Preferences... aus und geht nach 1. Mumie->Workspaces. Dort deaktiviert ihr die Option Remember Last Workspace. Jetzt müsst ihr Miau neu starten. Anschließend könnt ihr euch einen neuen Workspace erstellen, z.B. Mumie2.

Einrichten des Workspaces

Wie schon in der Analysis müsst ihr zunächst mit Window->Show Perspective->SVN Repository Exploring ein SVN-Repository konfigurieren. Dazu mit Rechts in die linke weiße Fläche klicken und dann New->Repository location... wählen. Die URL ist [[https://svn.mumie.net/]], die Account-Daten sind die normalen SVN-Daten. Anschließend müsst ihr folgende Pakete auschecken (jeweils den trunk!):

  • unter software_il die Pakete mmsrv_lsp, extension_il_omb, mathletfactory_lib und mmsrv_omb
  • unter content_and_courses->il das Paket content_il_omb

Jetzt wechselt ihr zurück in die Mumie-Perspektive. Unter Extras->Compile System Packages... wählt ihr die Pakete mmsrv_lsp, mmsrv_omb, mathletfactory_lib und extension_ol_omb und clickt dann auf Compile. Nachdem das Compilieren beendet ist, müsst ihr noch Extras->Refresh Workspace und Extras->Update Classpath of all packages ausführen. Sollte später eine Fehlermeldung kommen, dass er das Paket extension_il_omb nicht kennt, dann müsst ihr diesen Punkt möglicherweise noch einmal ausführen.

Jetzt wählt ihr links den Checkin Tree-View an. Unter content->il->omb->media->applets liegt das GenericMCApplet. Dieses müsst ihr compilieren (einfach anwählen und Compile). Ebenso unter content->il->omb->problems->correctors den GenericMCCorrector.

Zum Schluss müsst ihr noch im Package View auf content_il_omb rechtsclicken. In Properties->Resource wählt ihr dann bei Text File Encoding die Option Inherited from Container. Wenn ihr das vergesst, dann sehen Umlaute im Miau lustig aus. Nun könnt ihr arbeiten.

Damit die Sprache korrekt im Preview angezeigt wird, müsst ihr in der Mumie-Perspektive auf den Checkin-Tree wechseln, dort content->il->omb anwählen, und dann oben im Toolbar ganz rechts bei den Previews "German" auswählen. Sonst werden die falschen Sprachelemente im Preview benutzt. Ebenso sollt ihr bei Theme OMB auswählen.

Arbeitsablauf

Die Tickets bekommt ihr aus einem neuen Trac unter [[https://trac.mumie.net/content_il_analysis/]]. Zunächst sollt ihr nur die Artikel im Theorieteil bearbeiten. Dazu gibt es jeweils ein Ticket namens art_several_numbers oder so ähnlich. <del>Am Ticket hängt ein File mit dem Sourcecode des Originaldokuments.</del> Für Artikel liegt der Sourcecode des Originaldokuments als .tex-File im Dokumentenbaum. Dieses File könnt ihr löschen, sobald ihr den Artikel angelegt habt. Exercises sind schon in der richtigen Form eingestellt, compilieren aber noch nicht. Der Name der Component ist wie gewohnt der Pfad im Dokumentbaum. Da Artikel noch nicht einfach angelegt werden können, kopiert ihr am einfachsten einen bestehenden Artikel, und ändert dann den Namen und Inhalt der Kopie entsprechend. Bitte auch die Meta-Info <del>und die Sprachweichen</del> nicht vergessen! Compilieren könnt ihr wie gewohnt.

Der Workflow im Trac ist etwas anders als ihr es aus der Analysis kennt. Wenn ihr ein Ticket zum ersten Mal bearbeiten könnt, dann wird es auf "implementable" gesetzt. Wenn das Ticket problemlos compiliert und auch sonst alles in Ordnung ist, dann setzt ihr es auf "testable". Wenn es Probleme z.B. durch fehlende oder fehlerhafte TeX-Befehle gibt, oder wenn Bilder oder sogar Teile des TeX fehlen (z.B. Lösungen bei einigen Exercises), dann setzt ihr es auf "on-hold". Bitte dabei daran denken, dass ein Verweis auf das Ticket eingefügt wird, das den Block verursacht.

Um Previews zu sehen, müsst ihr in Miau im Hauptmenü unter Command->Advanced->Compile System Packages... gehen und dort mmsrv_system_entities auswählen und compilieren. Anschließend könnt ihr wie gewohnt mit dem Preview-Button arbeiten.

Wenn beim Compilieren etwas schief geht, weil z.B. mmtex einen Befehl noch nicht kennt, dann erstellt ihr ein Bug-Ticket im Trac mit einer Beschreibung des Fehlers. Anschließend kommentiert ihr die fehlerhafte Stelle aus und macht weiter bis zum nächsten Fehler.

Ein Bug-Ticket im Trac erstellt ihr mit "New Ticket". Vorher bitte unbedingt prüfen, ob ein Ticket zu diesem Fehler schon existiert, sonst haben wir irgendwann alles doppelt und dreifach im Trac! Als Titel gebt ihr am besten den Namen des fehlenden/fehlerhaften Befehls an. Die Beschreibung sollte erkennen lassen, was konkret nicht funktioniert (Befehl existiert nicht, verhält sich nicht wie gewünscht, etc.), und unbedingt auch ein Verweis auf das Ticket bzw. File, bei dem der Fehler auftrat. Bei "Type" wählt ihr "bug" aus, bei "Component" wählt ihr "Miau". Die anderen Felder müsst ihr nicht ändern. Ihr solltet in das ursprüngliche Ticket, also das Ticket für den Inhalt, einen Kommentar mit der Nummer des Bug-Tickets eintragen (also z.B. "geblockt durch #37"), damit man leicht sehen kann, welche Probleme beseitigt werden müssen, bevor das andere Ticket fertig bearbeitet werden kann.

Wenn ein Fehler korrigiert wurde, also z.B. ein neues TeX-Kommando implementiert oder ein Workaround festgelegt wurde, dann erfahrt ihr das per Mail und/oder per Trac. Gegebenenfalls müsst ihr dann euer Miau updaten (siehe unten). Viele im Original-Brückenkurs verwendete LaTeX-Kommandos können durch bereits existierende mmtex-Befehle nachgebildet werden. Eine Liste mit bekannten Workarounds findet sich ganz unten auf dieser Seite.

<del>Bitte vergesst auch nicht, die Sprachweichen in die Texte einzubauen. Bisher gibt es ja nur die deutschen Texte, aber im Hinblick auf spätere Erweiterungen ist das wichtig.</del> Die Sprachweichen könnt ihr erst einmal weglassen. Das ist für die erste Phase des Brückenkurses nicht notwendig.

Bilder

Die Bilder in den Theorieteilen sind im SVN unter media/images und können wie gewohnt eingebunden werden. Die Bilder in den Übungen sind etwas schwieriger. Wir mussten die Dateien selbst von der Webseite herunterladen und teilweise konvertieren. Aus diesem Grund sind die Namen der Bilder im Moiau teilweise nicht mit denen im Wiki identisch, insbesondere bei den Lösungen. Wo möglich, sind die Namen im Trac eingetragen. Ansonsten ist hoffentlich der Name so aussagekräftig, dass die Bilder dem jeweiligen Dokument zugeordnet werden können.

Übungen

Die Übungstickets sind etwas komplizierter als die Artikel und werden deshalb hier gesondert beschrieben. Das Hauptproblem ist, dass bei allen Übungen zunächst einmal die TeX-Quellen für die Lösungen fehlen. Diese müssen manuell hinzugefügt werden. Dazu braucht ihr den Zugang zum schwedischen Brückenkurswiki:

[[http://wiki.math.se/wikis/2009/bridgecourse1-TU-Berlin/index.php/Spezial:Anmelden]] für Teil 1

[[http://wiki.math.se/wikis/2009/bridgecourse2-TU-Berlin/index.php/Spezial:Anmelden]] für Teil 2

Solltet ihr keinen Account da haben, dann könnt ihr euch einfach einen anlegen (auf der Anmeldungsseite) und Dagmar Bescheid sagen. Sie schaltet dann die Rechte für euch frei.

Die Struktur der Übungen unterscheidet sich zwischen KTH und Mumie. Im Originalkurs gibt es zu einem Abschnitt, z.B. 1.1 im ersten Teil, eine Seite mit sämtlichen Übungen für diesen Abschnitt. Auf dieser Seite selbst befinden sich die Aufgabenstellungen für alle Übungen. Für jede Antwort und die Lösungen gibt es einen Link auf eine Extra-Seite.

In der Mumie gibt es ein Dokument pro Übung, für 1.1 also 1.1.1 bis 1.1.7. In jedem Dokument sind die Aufgabenstellung, die Antwort und die Lösungen für eine Aufgabe enthalten. Die Aufgabenstellung ist immer sichtbar. Ansonsten ist entweder die Antwort oder eine der Lösungen sichtbar. Das wird über das tabs*-Environment realisiert. Innerhalb einer Lösung werden die einzelnen Schritte manchmal nacheinander sichtbar gemacht. Das geschieht mittels des incremental-Environments.

Für die Konvertierung müsst ihr gelegentlich Sourcecode aus den Webseiten heraus kopieren. Dazu solltet ihr im Firefox das "NoScript"-Addon installieren, um bei Bedarf das Javascript auszuschalten, was den LaTeX-Code im Brückenkurs in HTML übersetzt. Das macht ihr über Tools->Addons->Get Addons, dort nach NoScript suchen, installieren, Firefox neu starten, fertig. Es ist übrigens auch ganz praktisch, um Dinge wie Google Analytics abzuschalten ;-) Standardmäßig sind alle Scripts ausgeschaltet Unten im Statusbar des Browsers gibt es ein Icon, mit dem ihr die Scripts einzeln an- und ausschalten könnt. Mit "Allow" werden Scripts aus einer Quelle permanent zugelassen. Mit "Temporarily allow" gilt die Erlaubnis nur bis zum Neustart des Browsers.

Chris hat schon einige der Sachen konvertiert und folgende Anleitung erstellt:

  1. Kleines Gerüst wie alle Lösungen aussehen.\\
    
    \begin{tabs*}[\initialtab{0}\class{exercise}]
    
    \tab[
    
    \lang{de}{Antwort}]
    
    \begin{table}
    
    a) $a$ & b) $b$ \\
    
    c) $c$ & d) $d$ \\
    
    e) $e$ & f) $f$
    
    \end{table}
    
    \tab[
    
    \lang{de}{L\"osung a}]
    
    \begin{incremental}[\initialsteps{1}]
    
    \step
    
    \end{incremental}
    
    \end{tabs*}
    
    
  2. Im Gerüst die richtigen Antworten eintragen.
  3. Im Gerüst so viele \tab Blöcke (Mit incremental etc.) per Copy/Paste hinzufügen wie es halt Aufgaben gibt.

So Gerüst ist fertig für die Aufgabe. Jetzt kann es gefüllt werden:

  1. Javascript blocken und zu jeder Aufgabe (habe nur direkt im Kurs gearbeitet nie auf "bearbeiten" oder so gehen.. zu umständlich) die Lösungen erst mal rüberkopieren (also immer hinter das vom Gerüst schon vorgegebene \step der jeweiligen Aufgabe)
  2. Javascript einschalten und sich eine Aufgabe nach der anderen vornehmen. Dabei immer so weit bearbeiten, wie der Schritt angezeigt wird. dann ein \step einfuegen. Im Browser einen weiteren Schritt anzeigen lassen... etc. (<del>Sprachweichen nicht vergessen!</del>)

Hinweis: bbox, firstcbox, secondcbox können ohne Bedenken durch emph[highlight] ersetzt werden. Die Argumente hinter den 3 Kommandos sind auch immer die gleichen. Dabei aber aufpassen bei first und second welches nun das richtige ist, das man benutzen soll, aber das sieht man ja in der Lösung im Browser.

Für Formeln im Text $$ und außerhalb am besten \[ \] verwenden, das geht am schnellsten.

Testen

t.b.d.

Online-Testen

Unter [[http://www.mumie-hosting.net/mmsrv]] haben wir jetzt einen Testserver für das Online-Testen aufgesetzt. Eure Usernamen sind die gleichen wie auf dem Analysis-Server, als Passwort habt ihr alle das streng geheime mumie01. Unter Kurse findet ihr die beiden Teile des Brückenkurs. Testen sollt ihr wiefolgt:

  1. Ticket mit Status online_testable suchen
  2. Dokument auf dem Testserver und dem originalen Brückenkurs öffnen
  3. Beide Versionen gründlich Schritt für Schritt vergleichen
  4. Wenn es keine Fehler gibt, dann auf approved setzen
  5. Korrigierbare Fehler (z.B. Vertipper) im Miau verbessern, ins SVN einchecken, Ticket auf incorrect setzen mit Vermerk "Bitte auf den Server hochladen"
  6. Für neue Fehler Bugticket anlegen
  7. Blocker im Ticket vermerken, Ticket auf incorrect setzen

Sven wird Tickets nach erfolgter Korrektur dann je nach Bedarf auf implementable, testable oder online_testable setzen. Wenn ihr ein Ticket selbst von testable auf online_testable gesetzt habt, dann überlasst den Online-Test nach Möglichkeit jemand anderem, damit möglichst viele verschiedene Leute darauf schauen können.

Testen von Aufgaben

Die Aufgaben sollen grundsätzlich so getestet werden wie die Hausaufgaben für die Analysis. Bitte testet sie nur auf dem Server, und zwar alle die Aufgaben, die im Trac als online_testable markiert sind. Die Ticket-Typen sind diagnostic test und final exam. Ihr findet die Aufgaben über den Navigationsbaum auf der linken Seite auf dem Server. Dort gehören zu jedem Abschnitt ein diagnostischer Test und eine Schlussprüfung. Wenn ihr darauf klickt, dann erscheint darunter ein kleines Icon, das euch zur eigentlichen Aufgabe führt.

Die Aufgaben müssen wieder wie gewohnt auf funktionale und sprachliche Korrektheit getestet werden. Das bedeutet, dass alle Links funktionieren müssen, es muss die richtige Aufgabe erscheinen, die Teilaufgaben müssen komplett bearbeitbar sein, Eingaben müssen korrekt gespeichert und wiederhergestellt werden, und auch so wie abgespeichert in der Korrektur verwendet werden. Testet dieses bitte auch mit verschiedenen Aufgabenstellungen (erhältlich mittels Neue Daten).

Bitte rechnet dann eine Aufgabe einmal durch, und überprüft, ob der Korrektor die richtige Lösung richtig korrigiert. Prüft auch, ob falsche Lösungen erkannt und als solche markiert werden.

Wenn ihr Fehler in den Applets findet, dann verwendet als Komponente für das Bugticket bitte exam. Tragt die Bugtickets bitte auch wie gewohnt als Blocker ein. Bevor ihr ein neues Bugticket anlegt, schaut bitte erst nach, ob schon eines für diesen Fehler existiert.

Englische Inhalte

Um die englischen Inhalte einzubinden, verwenden wir sowohl im Trac als auch in den Miau-Dokumenten das schon vorhandene Gerüst aus der ursprünglichen Migration. Hier zunächst die notwendigen Information zu Tools bzw. Baustellen:

  • das Miau ist einfach das aktuelle Miau
  • am besten verwendet ihr einen neuen Workspace, den ihr so wie oben in der Anleitung beschrieben einrichtet
  • nicht vergessen: als Theme im Workspace OMB auswählen, und als Sprache English!
  • die Tickets gibt es im [[https://trac.mumie.net/content_il_analysis|Trac]], filtert bei nach der Komponente OMB, für den Typ nehmt ihr is not applet, für den Status alles außer approved und closed
  • als Testserver verwendet bitte wie gewohnt [[https://test.mumie.net/il-content-dev|content-il-dev]]; Sprache auf Englisch nicht vergessen!
  • die originalen Inhalte findet hier: [[http:_wiki.math.se/wikis/2009/bridgecourse1-ImperialCollege/|Teil 1]] bzw. [[http:_wiki.math.se/wikis/2009/bridgecourse2-ImperialCollege/|Teil 2]]

Konzentriert euch zunächst auf die Articles und Exercises. NEU Jetzt könnt ihr auch diagnostische Tests und Schlussprüfungen bearbeiten. Die englischen Quellen findet ihr wie in der Tutorenbesprechung gezeigt über den ombtutor-Account bei den Schweden. Das Passwort ist immer noch achIJK20+. Folgendes ist zu tun:

  1. Die englischen Inhalte müssen per Sprachweiche in die existierenden Quellen eingebaut werden.
  2. Die Formatierung muss gegebenenfalls verbessert und angepasst werden. Orientiert euch dabei an den Hinweisen hier auf der Seite, die noch von der alten Migration stammen. Das könnt ihr alles noch im Preview vom Miau aus machen.
  3. Wenn ihr damit fertig seid, dann setzt ihr das Ticket auf testable. Ich lade es dann auf die Webseite und setze es danach auf online testable.
  4. Danach müssen die Inhalte noch einmal online korrekturgelesen werden, und zwar Inhalt und Formatierung. Wir gehen davon aus, dass die Leute vom Imperial College Englisch können, die Sprache sollte also korrekt sein. Wenn alles ok ist, dann geht das Ticket auf approved.

Einige englische Inhalte stimmen nicht mit den deutschen überein. In diesem Fall setzt ihr das Ticket auf incorrect mit einer Beschreibung der Abweichungen. Genauso geht es wieder bei gefundenen Fehlern bei der Onlinekorrektur.

Noch ein paar Hinweise:

  • Bitte setzt das Ticket nicht gleich auf incorrect sobald ihr den ersten Fehler gefunden habt, sondern arbeitet bis zum Ende durch und notiert alle gefundenen Fehler im Trac. Ansonsten brauchen wir zu viele Iterationen für ein Ticket, gerade wenn es größer ist wie z.B. ein Artikel.
  • Bitte achtet darauf, dass der TeX-Quellcode nach der Bearbeitung nicht aussieht, als hätte jemand seine Katze auf der Tastatur spielen lassen. Das macht es ungemein schwierig, im nachhinein noch Korrekturen daran vorzunehmen, weil man nichts findet. Also: nehmt euch etwas Zeit für eine anständige Formatierung der Sourcen, das spart langfristig Arbeit.
  • Um das parallele Testen der deutschen und englischen Version zu erleichtern, habe ich auf dem Testserver die Accounts ombtutor (für Englisch) und omblehrkraft (für Deutsch) eingerichtet. Das Passwort ist in beiden Fällen das altbekannte...

Updaten von Miau

Wenn es eine neue Version von Miau gibt, erfahrt ihr das per Email. Dann könnt ihr Miau beenden, eure aktuelle Version einfach löschen, und die neue Version dann installieren wie oben beschrieben.

Am besten macht ihr das alles auch ohne Email einmal zu Beginn eurer Schicht.

Bekannte Workarounds und Ersetzungen für LaTeX-Befehle

  • Symbole für Zahlenräume, z.B. N oder R nicht mit \textbf{} bzw. \mathbf{} realisieren, sondern mit \N, \R, \Z etc.
  • \noindent einfach auskommentieren
  • \url{web-adresse} kann durch \ehref{web-adresse}{web-adresse} ersetzt werden
  • \textit kann durch \emph ersetzt werden
  • \textbf kann durch \strong ersetzt werden
  • \texttt kann je nach Einzelfall durch \code für Code, \file für Dateinamen oder \keyb für Tastatureingaben ersetzt werden
  • \texteuro kann durch \euro ersetzt werden
  • \dfrac kann durch \frac ersetzt werden
  • \tfrac kann durch \frac ersetzt werden
  • \vspace und \vspace* können einfach entfernt werden
  • bei \begin{rule} bitte daran denken, dass als Argument danach der Name der rule angegeben werden muss, also z.B. \begin{rule}{Kommutativgesetz}.
  • einige Befehle sind nur im Math-Mode definiert, treten in den OMB-Sourcen aber außerhalb des Math-Modes auf (z.B. \setminus). Dort einfach mit $$ oder einem ähnlichen geeigneten Befehl einklammern.
  • \rm kann einfach entfernt werden
  • \dots kann durch \ldots ersetzt werden
  • \bbox kann in den Artikeln entfernt werden; manchmal (in den Übungen) wird es benutzt, um Teile einer Formel farbig zu hinterlegen, z.B. so: \bbox[#FEEAFE, 1.5pt;]{...}. Dann soll es durch \emph[highlight-1]{...} ersetzt werden.
  • \tabular kann durch eine geeignete \table ersetzt werden. Dabei müssen die korrekten Formatierungen beachtet werden.
  • \raggedright kann entfernt werden
  • \null kann entfernt werden
  • \textbackslash kann durch \backslash ersetzt werden
  • \tabular und \tabular* können beide durch eine geeignete \table ersetzt werden
  • \latex kann durch LaTeX ersetzt werden (kein Backslash!)
  • \biggl und \biggr können durch \left( bzw. \right) ersetzt werden
  • \not kann in seiner ursprünglichen Aufgabe zur logischen Negation von Operatoren (z.B. \not= für Ungleichheit) durch das entsprechende LaTeX-Kommando ersetzt werden, z.B. \neq; Wenn \not zum Durchstreichen von Zahlen o.ä. verwendet wurde, dann bitte durch \cancel ersetzen.
  • \gather kann durch \align ersetzt werden
  • \hbox kann entfernt werden. Dort, wo es benutzt wurde, um Text in mathematischen Umgebungen zu erzeugen, kann es durch \text ersetzt werden
  • \minipage kann durch \block ersetzt werden
  • \begin{tips} / \end{tips} kann durch \begin{block}[hint-box] und \end{block} ersetzt werden
  • \tag kann durch \text ersetzt werden
  • \parbox{} kann durch \begin{block} und \end{block} ersetzt werden
  • \tabularnewline kann durch \\\\ ersetzt werden
  • \mbox kann durch \text ersetzt werden
  • \begin{cases} \end{cases} kann durch \left\{ \begin{mtable} \end{mtable} \right\. nachgebildet werden
  • \mathop kann mit \limits bzw. \nolimits nachgebildet werden
  • \goodbreak kann entfernt werden
  • \strut kann entfernt werden
  • \smallint kann durch \int ersetzt werden
  • \displaybreak kann entfernt werden
  • \rlap kann entfernt werden
  • \hfill kann entfernt werden
  • \vphantom kann komplett entfernt werden, inklusive Argument. \vphantom{1 + 1} muss also komplett gelöscht werden, und darf nicht zu 1 + 1 geändert werden.
  • \phantom wird genau so behandelt wie \vphantom, also alles entfernen inklusive des Elements.
  • \newpage kann entfernt werden
  • \textstyle kann entfernt werden
  • \scriptstyle kann entfernt werden
  • \scriptscriptstyle kann entfernt werden
  • \textsc kann dadurch umgangen werden, dass der darin stehende Text in Großbuchstaben gesetzt wird.
  • \smash kann entfernt werden
  • \small kann entfernt werden
  • \boldsymbol kann durch \strong ersetzt werden
  • \break kann entfernt werden
  • \rowcolor kann entfernt werden (aufpassen, es hat viele Argumente)
  • \includegraphics wird durch \image nachgebildet. Dazu muss wie gewohnt in der Meta-Info eine Referenz zum entsprechenden Bild angelegt werden. Die Bilder liegen unter omb->media->images.
  • \hspace kann entfernt werden
  • \begin{flushleft} / \end{flushleft} kann entfernt werden
  • \heightbox kann entfernt werden. Achtung, das Kommando hat mehrere Parameter. Die ersten regeln nur die Größe, aber der letzter Parameter ist der Inhalt der Box, und der soll natürlich erhalten bleiben.
  • \firstcbox[...]{arg1}{arg2} und \secondcbox[...]{arg1}{arg2} werden durch \emph[highlight]{arg1} bzw. \emph[highlight]{arg2} ersetzt.
  • \centering kann entfernt werden
  • \vfill kann entfernt werden
  • \hss und \vss können entfernt werden
  • \begin{center} und \end{center} können entfernt werden
  • \stackrel{}{} kann durch \overset{}{} ersetzt werden
  • \multicolumn kann durch \colspan ersetzt werden
  • \begin{aligned}/\end{aligned} kann durch \begin{mtable}/\end{mtable} ersetzt werden
  • \allowdisplaybreaks kann mit all seinen Argumenten entfernt werden
  • Die schrägen Pfeile können durch die Kommandos \nearrow, \nwarrow, \swarrow und \searrow dargestellt werden.
  • \eqalign{} kann durch \begin{mtable}/\end{mtable} ersetzt werden
  • \cr kann durch \\ ersetzt werden
  • \matrix kann durch eine geeignete \mtable ersetzt werden
  • \begin{array} / \end{array} kann durch \begin{mtable} / \end{mtable} ersetzt werden
  • \textcolor{} kann durch \textstyle{mark-1}{} ersetzt werden. Wenn mehrere verschiedene Farben benötigt werden, dann entsprechend 'mark-2', 'mark-3' usw. benutzen
  • \hline kann durch geeignete \colspan{n} \hrule ersetzt werden
  • \cline kann vermutlich durch \colspan{n} \hrule ersetzt werden, bitte prüfen

Hinweise zur Verbesserung des Layouts

Der Arbeitsablauf ist ähnlich wie bei der ursprünglichen Portierung. Alles wird wieder über das Trac gesteuert. Ihr nehmt euch ein Ticket, dass testable ist, und vergleicht den Preview mit dem Original auf der OMB-Webseite. Dabei sollt ihr auf Unterschiede im Layout und im Inhalt prüfen. Einige der Probleme könnt und sollt ihr selber lösen, andere werden von uns zentral beseitigt. Wenn ein Ticket fertig ist, dann setzt es auf online testable. Bitte denkt daran, dass es auch immer noch Tickets geben kann, die implementable sind, und vergesst nicht, diese ebenfalls zu bearbeiten.

Probleme, die ihr selber lösen sollt

Weiter unten findet ihr eine Liste mit Lösungen für schon bekannte Probleme. Bitte schaut zuerst da nach. Teilweise sind die Lösungen nicht so einfach wie "Ersetze x durch y!", da müsst ihr ein bisschen probieren und mitdenken. Bei inhaltlichen Fehlern sollt ihr einfache Dinge wie z.B. Vorzeichenfehler oder vergessene Klammern selbst korrigieren. Wenn Inhalte fehlen, oder ihr euch nicht sicher seid, was zu tun ist, dann fragt nach.

Andere Probleme

Wenn es keine Lösung für ein Problem findet, setzt ihr das Ticket auf incorrect. Sollte ein Fehler beim Layout die Ursache sein, dann legt bitte wie gewohnt ein Bugticket an und vermerkt es wieder im entsprechenden Content-Ticket. Bitte unbedingt auch wieder im Bugticket eine Referenz auf ein Ticket mit angeben, wo der Fehler auftritt, sonst können wir das Problem nicht reproduzieren.

Bekannte Workarounds bzw. Fixes

  • Ihr braucht als erstes die korrekten MathML-Fonts für den Firefox. Diese findet ihr [[http://www.mumie.net/en/fonts.php|hier]]. Folgt dem ersten Link für Firefox 3, und ladet dort die STIX-Fonts + Beta runter. Installieren könnt ihr sie im KDE4 mittels Startmenü->Personal Settings->Font Installer->Personal Fonts->Add...
  • An einigen Stellen wird für Herleitungen etc. table benutzt. Besser ist es, stattdessen eqnarray zu verwenden. Dann gibt es keine hässlichen Rahmen, und die Formeln sind auf der Seite horizontal zentriert.
  • Wenn ihr feststellt, dass einige Styleklassen nichts tun bzw. nicht richtig funktionieren, wie z.B. momentan highlight oder omb-highl-1, dann legt dafür ein Bugticket an.
  • Die ~, die noch teilweise im Code stehen, werden durch Leerzeichen ersetzt.
  • Wenn ihr im Mathemodus einen Ausdruck in \nowrap{} setzt, z.B. \nowrap{3 + 3}, dann wird innerhalb des \nowrap kein Zeilenumbruch stattfinden. Bitte seid damit etwas vorsichtig, nicht einfach alles in \nowrap setzen, an einigen Stellen ist es ok, wenn ein Zeilenumbruch kommt.
  • In einer infobox (\begin{block}[info-box]{title}) wird nach dem Titel nicht automatisch ein Zeilenumbruch gemacht. Falls das ein Problem ist, weil danach z.B. Flie"stext kommt, könnt ihr einfach einem Absatz erzwingen, indem ihr eine Leerzeile einfügt. Das Title in {} ist übrigens irreführender Unsinn, das \begin{block}-Kommando kennt keinen Parameter für den Titel. {titel} wird einfach nur als ein Textblock in geschweiften Klammer interpretiert, der nicht irgendwie besonders formatiert wird.
  • Bei Konstrukten der Art $\underbrace{bla}_{blu \text{bli}}$ werden blu und bli in unterschiedlichen Fontgrößen gesetzt. Um das zu vermeiden, kann man einfach folgendes dafür ersetzen: \underbrace{bla}_{\text{$blu$ bli}}$. Bitte jeweils prüfen, ob das auch wirklich klappt! Das ist nur eine Notlösung, die im Firefox vielleicht geht, aber nicht 100%ig.
  • Wenn in Listen wie itemize oder enumerate das Label eines Unterpunktes der Liste im Vergleich zum Inhalt dieses Unterpunktes nicht richtig ausgerichtet ist, dann kann das Kommando \strut helfen. Dazu auch folgende Anleitung: Die automatische Ausrichtung des List-Items auf das List-Label ist schwierig, wenn das List-Item nicht mit einem normalen Absatz beginnt. Es gibt daher jetzt einen Befehl \strut, der die aktuelle Baseline auf die Baseline des Labels ausrichtet (sofern das möglich ist). Er fügt einen vertikalen Strich der Breite 0 ein, dessen Höhe dem Abstand der Baseline des Labels vom oberen Rand entspricht. Er sollte überall da eingefügt werden, wo der Inhalt des List-Items im Vergleich zum List-Label zu hoch ist. Benutzung im vorliegenden Fall:
    ''\begin{enumerate}
    \item[a.]
    \begin{table}[\class{layout}]
    \strut Bestimme die Länge des Kreisbogens.
    ... Im Mathemodus muss \strut@ in ein @\text{}'' verpackt werden, sonst funktioniert es nicht.
  • Tabellen ohne Rahmen gehen mit \begin{table}[\class{layout}].
  • Das Problem der hässlichen Zeilenumbrüche in den Tabellen mit den Aufgabenstellung und Lösungen in den Exercises lässt sich umgehen, indem ihr der Tabelle als optionales argument [\class{items}] mitgebt und dann den richtigen Stellen \nowrap verwendet.
  • Wir haben bei der Migration an vielen Stellen die \phantom{}-Kommandos dadurch entfernt, dass wir stattdessen mit \begin{align} gearbeitet haben. Leider macht das manchmal Probleme, z.B. in itemize. Hier muss auf das mittlerweile vorhandene \phantom zurückgegriffen werden.
  • Mit \emph[highlight-1]{} und \emph[highlight-2]{} könnt angeben, dass verschiedene Hintergrundfarben verwendet werden sollen. highlight-1 entspricht dabei dem alten highlight, bitte in Zukunft die neue Variante verwenden.
  • Lokale Links können mit den Kommandos \label{id} und \lref{id}{text} realisiert werden. \label{id} definiert dabei in einem Dokument das Ziel eines lokalen Links. id ist dabei ein beliebiger Identifier, z.B. label1. \lref{id}{text} fügt text als Link auf id ein, d.h. wenn man auf den Text klickt, dann springt die Seite zur Position des Labels.
  • Es gibt jetzt ein \center{}-Kommando und eine \begin{center}/\end{center}-Umgebung, mit denen sich Inhalte zentrieren lassen. Dies funktioniert nicht bei Tabellen, da muss das optionale Argument \align{c} für die table-Umgebung benutzt werden. Leider funktioniert die momentan noch nicht richtig, bitte baut es trotzdem erst einmal ein und setzt dann das entsprechende Bugticket als Blocker.

Add picture from clipboard (Maximum size: 500 MB)